Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12

Thread: Whole motor filled with gas

  1. #11
    Senior Member Improved
    Join Date
    Jan 2010
    Location
    Vermont
    Posts
    267


    Default

    Must have been the pump. With the new fuel pump rebuild kit in there, my buddy rode it all day the other day and it ran great. Although when I had the pump apart, I didn't notice any membranes torn. I did notice it had 2 sheets of the plastic stuck together on one side and only one on the other. My other phazer just had one sheet on each side (I rebuilt both machines fuel pumps this past friday). The rebuild kit only came with enough of those plastic sheets for one on each side. Maybe it was assembled improperly at the factory 30 yrs ago? Or maybe my problem was a stuck float and it could happen again? Going to install a fuel shutoff valve this summer. Not sure why they don't have one from the factory.
    Last edited by destey; 03-12-2019 at 02:17 PM.

  2. #12
    Senior Member ProStock mod-it's Avatar
    Join Date
    Nov 2006
    Location
    Lewiston, ID
    Posts
    784


    Default

    My girlfriend's RMK will draw a siphon and fill the cylinders every time I trailer it when the fuel tank is clear full. It had a fuel shut off when we bought it and it solves this problem...when I remember to shut if off that is. I got to have the fun of spraying fuel out the sparkplug holes last year because I forgot to shut it off. Of course it was when we arrived at our riding area and were ready to go ride right away. Didn't take long to get the fuel out, but waited an hour with it tipped on its side before being brave enough to fire it up.
    03 Mountain Viper, SLP Triples, SLP Flo-rites, gas rack, low profile blue windshield, NO underhood air going to the air box, (& no more powder bog)

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •