95 VMAX help needed


Maim

Super Moderator
Joined
Mar 13, 2004
Messages
3,867
Age
47
Location
sudbury on. canada
welcome!

#1 typically the cable was on a clip that went on one of the spring mount for the exhaust on the y pipe on most of the sleds i have seen.

#2 no that hole is supposed to remain open so you can see the water pump belt and check its tension.
 

Lakehouse2021

VIP Member
Joined
Sep 24, 2021
Messages
13
Location
Holly, Michigan
Next question: TORS.... I've been reading about it and know what it is and how it works.

I've only started the sled to get it off trailer and into the shop. I notice at idle there is a light thats on when sled is running. Does it go off when forward motion starts or is this an indication that it's not working on my sled?
 

Maim

Super Moderator
Joined
Mar 13, 2004
Messages
3,867
Age
47
Location
sudbury on. canada
tors does not have a light even on the new sleds and there it usually trips a code. light could be for oil level or coolant level unless you had the sled running long enough for it to overheat.
 

black dog

Life Member
Joined
Jan 31, 2019
Messages
45
Location
WA
Your sled does have a tors light. Should be lower right corner of gauge cluster. You will know if its working once you get the engine rpm over 4k. If it is stuck on, it may have been bypassed. Motion does not activate. It should light up when you fire the sled and then fade out
 

Lakehouse2021

VIP Member
Joined
Sep 24, 2021
Messages
13
Location
Holly, Michigan
Your sled does have a tors light. Should be lower right corner of gauge cluster. You will know if its working once you get the engine rpm over 4k. If it is stuck on, it may have been bypassed. Motion does not activate. It should light up when you fire the sled and then fade out
Thanks black dog! That is what I was hoping. I checked continuity today while pulling the carbs apart for cleaning and the switch is working fine. So my issue was just because of running the sled at idle speeds. Cool!! With only 870 miles on a 25 year old sled, I'm expecting good things from this one...

See link below, lower right corner of the display there is a red light that comes on

 
Last edited:

Lakehouse2021

VIP Member
Joined
Sep 24, 2021
Messages
13
Location
Holly, Michigan
Replacing fuel lines tonight. Fuel Line from tank to pump is 2 part, there is a male-male fitting where line goes underneath cowling. Question is, how much more work is it to get at the hidden section of the tube? Is it a barb fitting on the bottom of the tank or is it a siphon line that drops in the bottom of the tank?
 

Maim

Super Moderator
Joined
Mar 13, 2004
Messages
3,867
Age
47
Location
sudbury on. canada
on yamaha sleds it usually is a siphon tube from the top of the tank under the cowling. filter is on the bottom of the hose in the tank. i would reccomend replacing it as i have had one rot apart while sitting. ended up cleaning the carb multiple time because of my mistake.
 

Lakehouse2021

VIP Member
Joined
Sep 24, 2021
Messages
13
Location
Holly, Michigan
on yamaha sleds it usually is a siphon tube from the top of the tank under the cowling. filter is on the bottom of the hose in the tank. i would reccomend replacing it as i have had one rot apart while sitting. ended up cleaning the carb multiple time because of my mistake.
Thanks Sir, I was kind of anticipating that was the answer, because of course, I didnt purchase those pieces yet. Glad it's only October, I've got time to get them delivered...
 

Lakehouse2021

VIP Member
Joined
Sep 24, 2021
Messages
13
Location
Holly, Michigan
Thanks Guys, I'm rolling along! transfer case is flushed, all engine/fuel/air cleanup is done, next is the suspension, then I guess I'll be waiting awhile for snow.
I did want to ask about electrical plugs. This machine has no electric start/battery and I plan on going to the snow-show in Novi in a few weeks to pick up new helmet and gear. I'd like to get a heated shield on the helmet, can you suggest a plug kit or parts that I would wire into the grip warmers or other wiring that would mate with the helmet?

I haven't figured out how to upload pics greater than thumbnails, so here's the latest pic off my google drive:

 
Last edited:


Top